[PPL-devel] [GIT] ppl/ppl(sparse_matrices): New commits

Roberto Bagnara bagnara at cs.unipr.it
Sun Dec 11 17:11:44 CET 2011


URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=93e499e6c7f2878af0997fafe3cf6162a2f09e83
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sun Dec 11 17:07:38 2011 +0100

    Added new source file Linear_Expression_Impl.cc.
    Move template specializations that are not inline into new source file.
    Move other ones into Linear_Expression_Impl.inlines.hh.
    Prefer virtual method print() to non-standard virtual operator<< variant.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=013b9e8490bfce6318fae70a9895d819cd7355a2
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sun Dec 11 16:18:50 2011 +0100

    Avoid a couple of warnings about unused variables.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=f6b04c0181862825be3af8bb8fa2cfa387c62f54
Merge: 8ce105ecb82f5320fc972a5da320ca6726e3f1d4 5d56513b2dc23fae0bc40c822299f2cfc18dad35
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sun Dec 11 14:38:54 2011 +0100

    Merge branch 'master' into sparse_matrices
    
    Conflicts:
    	src/Grid_Generator.inlines.hh
    	src/Grid_conversion.cc
    	src/PIP_Tree.cc
    	src/Polyhedron_public.cc
    	src/globals.inlines.hh

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=5d56513b2dc23fae0bc40c822299f2cfc18dad35
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sat Dec 10 12:50:48 2011 +0100

    Added functions ppl_unreachable() and ppl_unreachable_msg(),
    causing program termination using abort().
    Let PPL_UNREACHABLE and PPL_ASSERT be based on these functions.
    Avoid a cycle in header inclusion dependencies.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=31dbca0af5eaf369f58e5b1f250c90ba744193de
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sat Dec 10 08:10:30 2011 +0100

    Corrected typo causing test failures.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=50504a0234039cab2e473884ed378a3058739412
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sat Dec 10 07:42:51 2011 +0100

    Prefer early return to dummy assignment in unreachable code path.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=9e39d6074bab1388bf7f63a58bcf1317f4c65ce2
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sat Dec 10 07:41:12 2011 +0100

    Add assignment to silence compiler warning.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=e7479b827db977fc493088ef56671f0b539f6b66
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Sat Dec 10 07:37:40 2011 +0100

    Fixed typo.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=e4cc508f1bfe1164358556884cd44474485c50a1
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 18:46:44 2011 +0100

    Improved name of helper function in OCaml interface.
    Add default label to switch to avoid warning.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=3c49e9f58f55eb1dd2302b35d3ec8f05d2673a96
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 18:31:20 2011 +0100

    Added debugging macro PPL_EXPECT_HEAVY.
    Added debugging helper function template copy_contains().
    Systematically use PPL_EXPECT_HEAVY(copy_contains(...)) when checking
    containment assumptions in widening/narrowing methods.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=3440f5a82c511096e4070825fb85c5374b6ddb72
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 17:41:47 2011 +0100

    Better differentiate between unreachable code and unexpected values.
    We call, e.g., PPL_JAVA_UNEXPECTED when we are converting an illegal
    Java value to a C++ value; we call PPL_UNREACHABLE when such a mismatch
    occurs the other way round (an illegal C++ value produced by the core library).

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=8c89cabcad0b8e807538ec7dbc75985936ef621e
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 15:10:42 2011 +0100

    Prefer if statement to switch having a single case.
    Detected by ECLAIR service swchlabs.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=17c7d99b34eb7abbb25de24b0ff7a200fb3da598
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 14:27:14 2011 +0100

    Prefer if-then-else to switch having a single case label.
    Detected by ECLAIR service swchlabs.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=d4b12db130c32ffef28b1af89134ffd3e61b4729
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 13:53:56 2011 +0100

    Added macro PPL_C_UNREACHABLE_MSG.
    Use the new macro in a few places in the C interface code.
    Standardized messages for errors due to Watchdog library not enabled.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=9438c7071464cf487210f64b6c89d28319ae535e
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 13:40:22 2011 +0100

    Added macros PPL_OCAML_UNREACHABLE and PPL_OCAML_UNREACHABLE_MSG.
    Try and use them systematically in the OCaml interface.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=9a523cbe043fadf5880067883d00bf45792193d9
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 13:02:40 2011 +0100

    Added new macro PPL_JAVA_UNREACHABLE.
    Use the new macro to mark unreachable code in the Java interface files.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=d08420c8dc65a0f20a713d305862e967892a6e70
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 12:58:29 2011 +0100

    Replaced throws of runtime_error exceptions by calls to PPL_UNREACHABLE.
    Got rid of a few (now unused) exception throwers.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=31a0bdcb139c64be85ed4765cb1f50d1f46f1739
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:26:13 2011 +0100

    Avoid (unreachable) default label when all cases have been listed.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=3849aea53fcb8aabe15a8093f8260c48749bf0e0
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:23:36 2011 +0100

    Prefer PPL_UNREACHABLE to PPL_ASSERT(0).
    Avoid mixing reachable and unreachable code paths.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=14344113942d2c1c93d4feb075a5275f96a8024a
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:22:27 2011 +0100

    Replaced an occurrence of PPL_ASSERT(0) by PPL_UNREACHABLE.
    Added an assertion and comment explaining why cases are unreachable.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=d3265acda1a51a53ff7dca7a06c065f7a76898c0
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:20:54 2011 +0100

    Replaced an occurrence of PPL_ASSERT(0) by PPL_UNREACHABLE.
    Added proper assertion for preconditions.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=7c636fa0e8837520706d20e036c79c1603357c48
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 09:42:20 2011 +0100

    Prefer if-then-else construct to binary switch.
    Detected by ECLAIR service swchlabs.
    
    Prefer listing a couple of residual switch cases to default label.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=eb0fe79c7af7bfb670c2db6928ade6d9c841a6ef
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 09:20:35 2011 +0100

    Replaced PPL_ASSERT(false) with PPL_UNREACHABLE.
    For readability, avoid mixing reachable and unreachable paths.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=1bc6cf294d3c34fd4e7d23fe611255591af63348
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 09:16:19 2011 +0100

    Prefer if-then-else construct to binary switch.
    Detected by ECLAIR service swchlabs.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=13865670123acb5f6c534155ab92f5ee7375ff94
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 08:56:38 2011 +0100

    Fixed a couple of switch statements where we were mixing reachable
    and unreachable code paths, reducing readability.
    Added precondition assertions at the start of assign_special_float()
    so as to make clearer why the default switch case is unreachable.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=5adf6d4df3cc59d8d39d736e868d99f2809cd86b
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 08:25:19 2011 +0100

    Added new macro PPL_UNREACHABLE, to be used instead of PPL_ASSERT(false).
    Started replacing calls to PPL_ASSERT(false) in the core library code.




More information about the PPL-devel mailing list