[PPL-devel] [GIT] ppl/ppl(master): New commits

Roberto Bagnara bagnara at cs.unipr.it
Fri Dec 9 14:13:23 CET 2011


URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=d4b12db130c32ffef28b1af89134ffd3e61b4729
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 13:53:56 2011 +0100

    Added macro PPL_C_UNREACHABLE_MSG.
    Use the new macro in a few places in the C interface code.
    Standardized messages for errors due to Watchdog library not enabled.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=9438c7071464cf487210f64b6c89d28319ae535e
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 13:40:22 2011 +0100

    Added macros PPL_OCAML_UNREACHABLE and PPL_OCAML_UNREACHABLE_MSG.
    Try and use them systematically in the OCaml interface.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=9a523cbe043fadf5880067883d00bf45792193d9
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 13:02:40 2011 +0100

    Added new macro PPL_JAVA_UNREACHABLE.
    Use the new macro to mark unreachable code in the Java interface files.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=d08420c8dc65a0f20a713d305862e967892a6e70
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 12:58:29 2011 +0100

    Replaced throws of runtime_error exceptions by calls to PPL_UNREACHABLE.
    Got rid of a few (now unused) exception throwers.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=31a0bdcb139c64be85ed4765cb1f50d1f46f1739
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:26:13 2011 +0100

    Avoid (unreachable) default label when all cases have been listed.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=3849aea53fcb8aabe15a8093f8260c48749bf0e0
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:23:36 2011 +0100

    Prefer PPL_UNREACHABLE to PPL_ASSERT(0).
    Avoid mixing reachable and unreachable code paths.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=14344113942d2c1c93d4feb075a5275f96a8024a
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:22:27 2011 +0100

    Replaced an occurrence of PPL_ASSERT(0) by PPL_UNREACHABLE.
    Added an assertion and comment explaining why cases are unreachable.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=d3265acda1a51a53ff7dca7a06c065f7a76898c0
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 11:20:54 2011 +0100

    Replaced an occurrence of PPL_ASSERT(0) by PPL_UNREACHABLE.
    Added proper assertion for preconditions.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=7c636fa0e8837520706d20e036c79c1603357c48
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 09:42:20 2011 +0100

    Prefer if-then-else construct to binary switch.
    Detected by ECLAIR service swchlabs.
    
    Prefer listing a couple of residual switch cases to default label.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=eb0fe79c7af7bfb670c2db6928ade6d9c841a6ef
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 09:20:35 2011 +0100

    Replaced PPL_ASSERT(false) with PPL_UNREACHABLE.
    For readability, avoid mixing reachable and unreachable paths.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=1bc6cf294d3c34fd4e7d23fe611255591af63348
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 09:16:19 2011 +0100

    Prefer if-then-else construct to binary switch.
    Detected by ECLAIR service swchlabs.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=13865670123acb5f6c534155ab92f5ee7375ff94
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 08:56:38 2011 +0100

    Fixed a couple of switch statements where we were mixing reachable
    and unreachable code paths, reducing readability.
    Added precondition assertions at the start of assign_special_float()
    so as to make clearer why the default switch case is unreachable.

URL:    http://www.cs.unipr.it/git/gitweb.cgi?p=ppl/ppl.git;a=commit;h=5adf6d4df3cc59d8d39d736e868d99f2809cd86b
Author: Enea Zaffanella <zaffanella at cs.unipr.it>
Date:   Fri Dec 9 08:25:19 2011 +0100

    Added new macro PPL_UNREACHABLE, to be used instead of PPL_ASSERT(false).
    Started replacing calls to PPL_ASSERT(false) in the core library code.




More information about the PPL-devel mailing list